Delayed SendGrid Email Statistics
Incident Report for SendGrid
Resolved
Our team has rectified the stats delays for affected statistics.All services are now operating normally at this time. We thank you for your patience as we worked to resolve this.
Posted Nov 19, 2022 - 15:09 PST
Update
We are continuing to monitor the resolution of this issue. We will provide another update in the next 24 hours or as soon as possible.
Posted Nov 19, 2022 - 14:28 PST
Monitoring
Beginning at 1:26 PM PT on November 16th, our engineering team determined that various statistic types for SendGrid were posted with more delays than expected. Users accessing Mailbox Provider Stats, Email Clients & Devices Stats, Browser Stats, Geographical Stats, and Monthly/Weekly Category Stats are delayed up to 48 hours before being posted to the SendGrid system. Global Stats and Daily Category Stats are not affected.

These stats delays do not impact mail send. Stats posting delays will vary between users.

Our engineering team made a deploy to rectify delays in the affected statistics. These deployed changes are anticipated to stabilize the SendGrid stats posting system but will require time to finalize. Statistics may continue to have delays until this incident is resolved.

Another update will be provided within the next 24 hours or as soon as more information is available.
Posted Nov 18, 2022 - 15:30 PST
This incident affected: Statistics.