Incomplete Advanced Statistics

Incident Report for SendGrid

Update

We are continuing to investigate this issue and will provide an update in the next hour or as soon as more information becomes available.
Posted Feb 11, 2026 - 11:46 PST

Investigating

Starting around 1pm PST on February 7th, our engineers began investigating an issue with Advanced Statistics (Geographical, Mailbox Provider, Browser, etc.). Customer may experience Incomplete Advanced Statistics for the following date and time frames: 1pm - 5pm PST and 7pm - 9pm PST on 02/07/2026. This does not impact mail send. We will provide another update in an hour or as soon as more information becomes available.
Posted Feb 11, 2026 - 10:46 PST
This incident affects: Statistics.