Click Tracking degradation
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with click tracking has been resolved. All services are now operating normally at this time.
Posted Nov 21, 2024 - 02:23 PST
Investigating
As of approximately 1:30 AM PST on Thursday, November 21, 2024, our engineers began investigating an issue impacting Click Tracking URLs using 'ct.sendgrid.net'.

This issue affects customers who have enabled click tracking but have not configured link branding.

This does not affect mail send.

Our team is actively working to identify the root cause and will provide updates within the next hour or as new information becomes available.
Posted Nov 21, 2024 - 01:53 PST