Service Disruption - Increase in Deferred, Block, or Bounce Messages with DNS Related Responses

Incident Report for SendGrid

Resolved

Our engineers have been monitoring the situation and it appears that Deferred, Block, and Bounce messages with `55x` or `5.1.8` DNS related responses have gradually decreased since our fix. Although the majority of this issue has been mitigated, some users may still see lingering effects while DNS changes continue to propagate. We apologize for any inconvenience this has caused you and thank you for your patience. If you have any questions, please reach out to our Support team at https://support.sendgrid.com.
Posted 5 years ago. May 19, 2020 - 18:36 PDT

Monitoring

Starting around 1pm MT on Monday, May 18th, customers may have noticed an increase in Deferred, Block, or Bounce messages with `55x` DNS related responses. Our engineers have implemented a fix and are now monitoring. We apologize for any inconvenience this may have caused. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted 5 years ago. May 19, 2020 - 15:49 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).