Errors when Attempting to Assign or Unassign IPs to Subusers
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue has been resolved. All services are now operating normally at this time.
Posted Jan 09, 2023 - 17:05 PST
Monitoring
A fix has been implemented and customers should no longer see errors when assigning or un-assigning IPs to subusers via the API or within the UI.

The fix has also resolved the inability to reach Support via the Support Portal. Customers should now be able to utilize chats and submit tickets as expected. We will provide another update within an hour or sooner if more information becomes available.
Posted Jan 09, 2023 - 16:35 PST
Investigating
Starting around 3:34 PM PT on January 9, 2022, our engineers began investigating an issue with endpoints related to assigning IPs to subusers. Customer may receive a 500 response when accessing any /v3/send_ips/pools/ endpoints or attempting to assign or unassign IPs to subusers. This does not impact the mail send endpoint.

This also impacts customer's ability to contact Support. Customers can submit a ticket to help@sendgrid.com in the meantime. You can reach our support team at We will provide another update in an hour or as soon as more information becomes available.
Posted Jan 09, 2023 - 16:19 PST
This incident affected: API and Website.