Users unable to complete Signup Provision Process
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue has been resolved. All services are now operating normally at this time.
Posted Jul 23, 2024 - 07:20 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2024 - 07:18 PDT
Investigating
On July 23rd at 6:20 A.M. (PST) Our engineers have identified the issue with Signup Provisions. Users may experience issues when signing up for new accounts. We are working toward a fix and will provide another update in hour or as soon as more information becomes available.
Posted Jul 23, 2024 - 06:34 PDT
This incident affected: Website.