Invoices corrupted after downloading them from the SendGrid interface
Incident Report for SendGrid
Resolved
Our engineers have confirmed that the issue with downloading invoices from the SendGrid account interface has been resolved. All services are now operating normally at this time.
Posted Apr 05, 2023 - 11:23 PDT
Monitoring
Our engineers believe this issue is resolved and all customers can now access invoices from within the SendGrid account interface as expected. We'll continue to monitor and provide another update within 30 minutes.
Posted Apr 05, 2023 - 10:53 PDT
Update
Our engineers are still investigating the root cause of the issue. Customers may experience trouble downloading invoices from the SendGrid platform at this time. We will provide another update in an hour or as soon as more information becomes available.
Posted Apr 05, 2023 - 10:25 PDT
Update
Our engineers are still investigating the root cause of the issue. Customers may experience trouble downloading invoices from the SendGrid platform at this time. We will provide another update in an hour or as soon as more information becomes available.
Posted Apr 05, 2023 - 09:27 PDT
Investigating
Starting April 5th, 2023 at around 8:00 am PDT our engineers began investigating an issue with invoices downloaded through the SendGrid platform. Users may experience errors when opening the invoices after downloading them from the SendGrid account directly. This does not impact mail send. We will provide an update in 1 hour or as soon as more information is available.
Posted Apr 05, 2023 - 08:27 PDT
This incident affected: Billing.