Mail Send Delays
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with Email Send delays has been resolved. All services are now operating normally at this time.
Posted Feb 29, 2024 - 00:39 PST
Monitoring
Starting around 06:17 AM UTC on the 29th of February 2024, our engineers have began investigating an issue with mail send requests delays for SMTP and API due to one of our servers. We moved the mail trafic to another healthy server around 6:47 AM UTC and we are currently monitoring the mail send performance. However, users may still had some mail delays within the timeframe specified.
Posted Feb 28, 2024 - 23:57 PST
This incident affected: Mail Sending (API v3, SMTP, API v2).