Technical Incident - Mail Delays
Incident Report for SendGrid
Resolved
We have monitored the situation and confirmed that the issue has been resolved. All of our affected systems are caught up and processing requests normally once again. We apologize for any inconvenience and thank you for your patience.
Posted Feb 02, 2021 - 17:16 PST
Monitoring
We can confirm that the delayed mail has been processed and we are currently monitoring our fix. We will provide an update within the next 60 minutes or less as updates become available. We apologize for any inconvenience and thank you for your patience.
Posted Feb 02, 2021 - 16:59 PST
Investigating
We are currently investigating mail delays that started today at 4:22PM MT. The delayed mail is currently being processed. We will provide an update within the next 60 minutes or less as updates become available. We apologize for any inconvenience and thank you for your patience.
Posted Feb 02, 2021 - 16:01 PST
This incident affected: Mail Sending (API v3, SMTP, API v2).